Which Transport Layer Security (TLS) protocol version does Hevo support?

Hevo supports the TLS protocol version 1.2 and above for enhanced data security.

As of Release 1.85, Hevo has deprecated TLS 1.0 and 1.1 because these are out-of-date protocols and do not support modern cryptographic algorithms. These protocols contain security vulnerabilities that may be exploited by cybercriminals. If you continue to use these older TLS versions, the connections or attempts to resume connection to Hevo app URLs and webhooks might fail.

To check if your browser or Source supports TLS 1.2 and above, do the following:

  • If you use a web browser to connect to https://<region>.hevodata.com, do a browser test and confirm that there is a Yes next to TLS 1.2 or higher in the Protocol Features section.

  • If you are using any Source or webhook such as Hubspot, PostgreSQL, or Shopify, refer to their respective documentation to ensure that they support TLS 1.2 and above.


Revision History

Refer to the following table for the list of key updates made to this page:

Date Release Description of Change
Nov-07-2022 NA Created as a new document.
Last updated on 04 Nov 2022

Tell us what went wrong