Error 1029 - Version not supported for Change Streams

Error Code 1029
Error Message Text(s) - Change Streams-based replication is only supported on MongoDB version 4.0 and above, yours is 3.x.x. Please try connecting with the OpLog mode.

Potential Causes

  • The MongoDB version is lower than 4.0. Change Streams-based replication is only supported on MongoDB version 4.0 and above.

Suggested Actions


See Also


Revision History

Refer to the following table for the list of key updates made to this page:

Date Release Description of Change
Sep-05-2022 NA Brought this page under its respective Source documentation folder.
Sep-20-2021 1.72 New document.
Last updated on 05 Sep 2022

Tell us what went wrong